HELP CENTER

Answers to your questions

Submit a request

hot issues

LightEaters requires iOS 7.1 for all devices.

 

LightEaters is available on the following devices:

  • iPhone: All models starting with 4s and newer (iPhone 5+ recommended)
  • iPad: All models starting with iPad 2 and newer (iPad 3+ recommended)
  • iPod Touch: All models starting with 5th generation and newer
  • iPad Mini: All models starting with iPad Mini and newer (iPad Mini 2+ recommended)

 

Jailbroken iOS devices are not supported.

 

 

Was this article helpful?

0 out of 0 found this helpful
Powered by Zendesk